jQuery 1.1將不會向下相容

根據jQuery Blog的文章The Path to 1.1,jQuery 1.1將在1月7號公開alpha版、14號正式公開(剛好一週年),然後值得注意的就是他將不會向下相容,不相容處如下所述:

  • 像是.onclick()和.unclick()的事件處理器會改成.one("click")和.unbind("click"),他們發現這些功能不是這麼的需要。
  • :nth-child()、:gt()、:lt()和:eq()選擇器將換改成由1開始計算,這樣才符合CSS的標準(這其實是一個bug fix)。
  • 部份的CSS相關函式像是.color()和.background()將不再被支援,你應該改成使用.css("color")和.css("background")這樣的方式。
  • 一些屬性的相關函式如.title()和.rel()也將取消,你應該改為使用.attr("title")和.attr("rel")。

我覺得這些改變都很不錯,把整個核心弄的更精簡了,或許還是會有人不習慣吧,也不用擔心,他還有說另外會有一個相容plugin讓你可以拿1.0的程式在1.1跑。

comments powered by Disqus